I need MIGUEL's help with Wireguard server

@miguel @miguel @miguel @miguel @miguel @miguel @miguel @miguel @miguel
Hello Mr. Miguel, I hope you are doing okay.
I have this Wireguard server setup on a remote Ubuntu 20.04 machine somewhere in the world. I have client to client talk enabled on the server and it works just fine if I connect Android, Linux, or Mac OS devices or Operating Systems to the server they can all talk to each other except for Windows. every time I try to connect Windows 10 to the server and then ping it from the other devices or from the main server it seems like all the packets are being dropped by WINDOWS FIREWALL which is really really driving my crazy. Do you or does anyone you know knows how to configuer Windows firewall in a way that it lets Wireguard packets from a remote server to be accepted? I know you are going to say disable Windows firewall but that is not the way I wanna do it.

How do you know it’s windows firewall that’s dropping the packets?

If you turn off windows firewall does ping work?

I have a wire guard network going and have 3 windows machines on it. The firewall is on and there isn’t any issue.

1 Like

I disabled it and everything worked smoothly

The issue on mine is that they can’t talk. like the wireguard server is fine and all the devices can talk except for Windows with Firewall turned on!

and I also added a rule in the firewall ( an Inbound rule ) to allow the wireguard app through the firewall but it doesn’t seem to work at all.

take a look at this Windows Firewall enabled Vs Windows Firewall disabled
Windows Firewall disabled:


Windows Firewall enabled:

There must be a way to make it work with Windows Firewall being turned on, but god Bill Gates made it so hard that I didn’t even find a single answer on the internet after looking for days not just hours! :grin:

here look at my firewall logs.


I can see that the packet comming from 10.66.66.1 to 10.66.66.2 which is the Windows client is being dropped for some reason. which makes no sense like why why is this happening?

I DID IT WOHOOOOO


I had to do this to allow all packets from the Wireguard VPN network and now it is officially working with a firewall in place.

Thank you so much :grin: :grin:

ok good stuff it’s working!

Lately, I’ve been using Tailscale for my VPN needs. It connects all your devices (using Wireguard), but without all the configuration, etc. Much easier and all my devices always have accessibility to each other.

I like experimenting with the stuff. I did this for no reason :slight_smile:

This is really smart is it open-source??